Back to overview
Sim IDX is down
Dec 4, 2025 at 3:28pm UTC
Affected services
IDX
Resolved
Dec 4, 2025 at 3:28pm UTC
Sim IDX cluster is not functioning
Affected services
Resolved
Dec 4, 2025 at 3:28pm UTC
Sim IDX cluster is not functioning
Affected services